Softwares y Versiones disponibles

Tabla de Referencia Rápida:

Apache

2.2.21

PHP

5.2.17 e 5.3.14

(funciona en paralelo)

Perl

5.8.8

MySQL

5.5.21 o superior

cPanel

11.32.x – actualizado automaticamente

GD / Image Magic

6.6.3

  • Sistema operativo: Linux x86 CentOS 6.x (64 bit) – versión gratuita del RedHat.
  • Kernel: última versión estable, actualizado segun necesidad.
  • Procesadores: Quad Core Dual Xeon E5520 2.26 GHz.
  • Apache 2.2.x (incluye mod_rewrite e mod_security) en ambiente SuExec.
  • Envio de email (SMTP): Exim.
  • Receptor de email (POP3 e IMAP): Dovecot
  • cPanel 11.32.x.
  • PHP 5.2.x e 5.3.x; o PHP corre como CGI (y no Apache/DSO) en ambiente suPHP.
  • Zend Optimizer 3.3.9
  • PEAR 1.7.x
  • ionCube 3.3.20, ionCube Loader 4.0.12
  • GnuPG 1.2.6
  • GD2 Library 2.0.34
  • openSSL 0.9.8o
  • SOAP
  • Modulos PHP.
  • phpMyAdmin 3.2.4.
  • Base de datos MySQL 5.5.x.
  • ROR Ruby 1.8.7, Gem 1.4.2, Rails 2.3.14.
  • cURL 7.15.x (asi como el libcurl y PHP/CURL).
  • PERL 5.8.x, Biblioteca PCRE 7.8.
  • Python 2.4 e 2.7 (corre paralelamente).
  • ImageMagick 6.6.x.
  • Ghostscript 8.15.x.
  • Rsync.
  • RoundCube 0.2b, SquirrelMail 1.4.13, Horde 3.1.7p8.
  • Parallels SiteBuilder 4.5.0.
  • Scripts do Fantastico Deluxe y QuickInstall: Blogs (ej.: WordPress), CMS (ej.: Drupal e Joomla), Forums (ej.: phpBB), Tiendas Virtuales (ej.: Magento), Galerias de Imagenes, Mailing Lists PHP, Constructores de Sitios, Aplicativos de Wiki etc.

 

Habilitando el PHP 5.3 o superior en tu sitio

Todos nuestros servidores soportan tanto el PHP 5.2 como el PHP 5.3.

La versión por defecto es el 5.2.x, pero usted puede seguir los siguientes pasos para habilitar la versión 5.3.x del PHP.

Antes de hacer los cambios bebe tener en cuenta que es posible que ocurran problemas de compatibilidad, pues los códigos más antiguos pueden no ser compatibles con las nuevas versiones del PHP.

Tenga esto en mente: habilitar el PHP 5.3 romperá cualquier sitio que necesiten del Zend o ioncube que hayan sido codificados con el PHP 5.2. Recomendamos que usted verifique con el des arrollador de la aplicación si existe una versión para el PHP 5.3 disponible.

Como habilitar PHP 5.3

Para poder habilitar la versión del PHP 5.3 siga estas instrucciones.

Actualmente tenemos instalados en nuestros servidores el PHP 5.3.10 (o superior).

Para poder habilitar la versión 5.3 del php es necesario usar un handler (control), esto usted deberá activarlo en su cuenta.

Para hacer uso de ese handler añada el siguiente código al archivo .htaccess.

# Habilitar el PHP 5.3 
AddType application/x-httpd-php53.php
# Habilitar el PHP 5.4 
AddType application/x-httpd-php54.php
# Habilitar el PHP 5.5 
AddType application/x-httpd-php55.php

Usted puede editar el archivo .htaccess directamente en en el cPanel utilizando el administrador de archivos o también via FTP.